О программе

Электронный авто каталог 5.x

Overview:

Электронный авто каталог содержит информацию по моделям и её составляющим - деталям и сборочным единицам. Позволяет просматривать структуру машины, искать детали в машина, делать заказ запчастей, просматривать документацию по узлам.

Особенности системы:

маркированный список | Состоит из клиентской и серверной частей
маркированный список | Поддержка 7 языков.
маркированный список | Справочная система
маркированный список | Структурированная база производителей и их продукции
маркированный список | Документы описания привязанные к моделям, узлам и деталям.
маркированный список | Древовидная структура узлов машины.
маркированный список | Широкие возможности поиска деталей и узлов.
маркированный список | Возможность работать с несколькими окнами каталога, документов, заказов.
маркированный список | Модификации узлов.
маркированный список | Справочник стандартных деталей.
маркированный список | Печать иллюстраций узлов и стандартных деталей.
маркированный список | Система аказов.
маркированный список | Работа с каталогом локально с жесткого диска, CD/DVD-ROM, или удалённо по сети, или с через интернет используя сервер производителя.
маркированный список | Шифрование и кэширование данных при работе через интернет.
маркированный список | Обновление через интернет.

AM logo
AM logo
© 2001-2006 ООО "Арт-Механика"


Системные требования

Требования к программному обеспечению:

Электронный каталог представляет собой программный комплекс, устанавливаемый и выполняющийся на компьютерах типа PC под управлением ОС Microsoft Windows 2000/XP.

Требования к аппаратному обеспечению:

Тех. Характеристики \ Конфигурация | Минимальная | Рекомендуемая
Процессор | 400 Мгц | 1 Ггц
CD-ROM | 12x | 32x
RAM | 128 Мб | 256-512 Мб
Свободного места на жестком диске | 10-500 Мб (в зависимости от поставки и способа установки)
Монитор | 15" | >=17"
Экранное разрешение | 1024x768 | 1280x1024
Цвет | 16 бит | 32 бита
AM logo
AM logo
© 2001-2006 ООО "Арт-Механика"


Как начать работу

Шаг 1

Для запуска программы Нажмите "Пуск [image] Программы [image] INTRALL [image] AutoCatalog" (рис.1.) или дважды кликните левой кнопкой мыши по иконке на рабочем столе:

Рис.1

Шаг 2

После запуска электронного каталога, если задан выбор БД при старте программы, необходимо выбрать БД для просмотра (рис.2):

Из списка доступных БазДанных (1) необходимо выбрать интересующую Вас. Локальная БазаДанных (БД) (находящаяся на вашем диске), созданная программой установки называется Default. В строке (2) отображается маршрут к локальной БД или сервер и порт для удалённого подключения. Если у Вас есть быстрое подключение к Интернет - можно использовать последнюю версию БД с сервера INTRALL, учтите, что работать программа через интернет будет существенно медленней.

ВНИМАНИЕ!!!

  • Для работы с системой заказов и выбора модели по VIN номеру необходимо подключение к интернет серверу.

  • Программа всегда будет пытаться соединиться с сервером INTRALL, даже если выбрана локальная БД.

  • Для подключения к интернет серверу необходимо пройти идентификацию, необходимо знать имя пользователя и пароль.

Рис.2

Для настройки доступа к БД и параметров подключения к серверу INTRALL, нажмите кнопку "Параметры", после этого произведите необходимые настройки в окне установок.

Для того, чтобы при старте программы не выводилось окно выбора БД, необходимо включить опцию "не выводить это окно при старте" (3).

Шаг 3

Далее откроется главное окно (рис.3). Для открытия каталога запчастей, в главном меню (1) выберите пункт «Каталог [image] Выбор модели», после чего откроется ОКНО ВЫБОРА МОДЕЛИ . Если Вы уже работали с каталогом каких-либо моделей, то можно выбрать их напрямую из списка (3), после этого открывается ОКНО КАТАЛОГА выбранной модели.

Рис.3

В строке состояния (4) будут отображаться сообщения о текущих действиях или информация окна каталога. Также в строке состояния отображаются подключения к БазамДанных. Локальное подключение и его тип (5) и удалённое подключение к серверу INTRALL (6).
AM logo
AM logo
© 2001-2006 ООО "Арт-Механика"


Окно "О программе"

В окне "О программе" содержится следующая информация.

1 Тип программы:
Модуль конструктора | - Версия программы для редактора каталога
Клиент | .- Версия программы для просмотра каталога и заказа запчастей
LE | - Версия программы с ограниченными функциями.
CD Only | - Версия программы привязанной к установочному компакт диску.
2 | Номер версии
3 | Использование аппаратного ключа
4 | Строка статуса, появляется при запуске программы и отображает действия программы

AM logo
AM logo
© 2001-2006 ООО "Арт-Механика"


Главное меню

Меню «Каталог деталей» содержит следующие пункты:

 | Название | Описание
1 | Новый | Создает новое окно каталога. Перед созданием необходимо выбрать модель в окне выбора модели . Для управления окнами можно использовать кнопки вынесенные на панель инструментов или из меню «Окна».
2 | Выбор модели | Выбор модели для активного окна каталога.Открывает окно выбора модели.
3 | Закрыть | Закрывает активное окно каталога.
4 | Закладки | Меню закладки.Закладки позволяют запоминать и быстро возвращаться на необходимые детали в узле. Закладки действуют в пределах активного окна каталога.
5 | Документы | .
6 | Дерево | .
7 | Печать | Вызывает печать страницы каталога выбранной детали.
8 | Поиск детали | Открывает окно поиска
9 | Содержимое в узлах | .
10 | Поиск в ветке дерева | .
11 | Заказ детали | Открывает плавающее окно заказа детали
12 | История открытых моделей | .
13 | Выйти из программы | Завершение работы с программой.

Меню «Заказы» содержит следующие пункты:

 | Название | Описание
1 | Создать окно заказов |
2 | Закрыть окно заказов |

Меню «Вид» содержит следующие пункты:

 | Название | Описание
1 | Вкл/Выкл полноэкранный режим | Переключает вид отображения каталога. По умолчанию программа запускается в не полноэкранном режиме. Включение полноэкранного режима убирает все элементы интерфейса, кроме главного меню и иллюстрации детали.
2 | Масштаб | Позволяет выбрать масштаб иллюстрации детали из выпадающего списка заданных масштабов. Для произвольного масштабирования можно использовать кнопки на панели инструментов. Также возможно включение авто-масштаба, при этом все отображения деталей будут масштабироваться до оптимального размера.
3 | Показать строку состояния | Позволяет вкл/выкл строку состояния.
4 | Показать панель инструментов | Позволяет вкл/выкл панель инструментов.
5 | Панель инструментов | Позволяет выбрать необходимые инструменты на панели инструментов и отключить неиспользуемые. Выбор инструментов осуществляется из выпадающего меню.

Меню «Окна» содержит следующие пункты:

 | Название | Описание
1 | Упорядочить горизонтально | Размещает открытые окна каталога друг над другом.
 | Упорядочить вертикально | Размещает открытые окна каталога в ряд.
2 |  | В меню активное окно помечается меткой слева. Выбрав окно из этого списка, вы тем самым делаете его активным. Для открытия новых окон можно воспользоваться меню «Каталог деталей».

Меню «Сервис» содержит следующие пункты:

 | Название | Описание
1 | Настройки | Открывает окно настроек
2 | Конфигурация Базы Данных | Выбор из имеющихся конфигураций Баз Данных. Конфигурации БД создаются в окне настроек. Программа закроет все окна каталога и откроет последнюю активную модель, если она будет найдена в новой БД. Если Вы пользуетесь БД с компакт диска, то пункт "Сменить диск с БД" позволит менять БД моделей простой сменой диска.

Меню «Справка» содержит следующие пункты:

 | Название | Описание
1 | Справка | Открывает эту систему справки
2 | О программе | Открывает окно, содержащее название и версию программы, а также контактную информацию разработчика.

Меню «Документ» содержит следующие пункты:

 | Название | Описание
1 | Закрыть окно | Закрывает текущий документ
2 | Назад | Назад на предыдущий документ
3 | Вперёд | Вперёд на следующий документ
4 | Остановить | Остановить загрузку документа
5 | Печать | Печать текущего документа на принтер
6 | Поиск | Поиск текста в документе
7 | Выйти из программы | Закрыть программу автокаталога

AM logo
AM logo
© 2001-2006 ООО "Арт-Механика"


Панель инструментов

Панель инструментов, поможет быстро вызвать часто используемые действия. Состав панели инструментов можно менять через меню "Вид [image] Панель инструментов" или нажав правую клавишу мыши на панели инструментов. Все инструменты разбиты на несколько групп.

Группа «Каталог» содержит следующие инструменты:

 | Название | Описание
1 | Новый | Создает новое окно каталога. Перед созданием необходимо выбрать модель в окне выбора модели . Для управления окнами можно использовать кнопки вынесенные на панель инструментов или из меню «Окна».
2 | Выбор модели | Выбор модели для активного окна каталога.Открывает окно выбора модели.
3 | Закрыть | Закрывает активное окно каталога.

Группа «Дерево» содержит следующие инструменты:

 | Название | Описание
1 | На уровень вверх | Перемещение выше по дереву в родительский узел.
2 | Внутрь узла | Перемещение в глубь дерева.
3 | Поиск в дереве по... | Содержит выпадающий список, в котором можно выбрать один из способов поиска узлов и деталей в дереве: по номеру или названию и по начальным или по включению.
4 | Сортировка по ... | Содержит выпадающий список, в котором можно выбрать один из трех способов сортировки дерева узлов и деталей: по номеру, названию или без сортировки.
5 | Вкл/Выкл пользовательскую структуру каталога | Если доступна пользовательская структура модели, её можно включать/отключать.
6 | Вкл/Выкл связь между структурами | Если доступна пользовательская структура модели, можно включить эту опцию, тогда переход в одной структуре будет автоматически синхронизироваться с другой, если это будет возможно.
7 | Переключиться между структурами |

Группа «Деталь» содержит следующие инструменты:

 | Название | Описание
1 | Дополнительная информация о детали | Открывает окно дополнительной информации о детали.
2 | Информация о модификациях детали | Открывает окно информации о модификациях узла.
3 | Показать информацию по ремкомплекту | Открывает окно информации по ремонтному комплекту.
4 | Показать кол-во детали в моделях | Производит подсчёт количества деталей во всех моделях.
5 | Инструкция по эксплуатации узла | Открывает документацию по эксплуатации узла.
6 | Инструкция по ремонту узла | Открывает документацию по ремонту узла.
7 | Все документы по модели | Открывает окно, позволяющее просматривать все документы по модели.
8 | Заказ детали | Открывает плавающее окно заказа детали

Группа «Поиск» содержит следующие инструменты:

 | Название | Описание
1 | Поиск в ветке дерева | Вызывает поиск детали в ветке дерева
2 | Найти где содержиться | Вызывает окно поиска узлов в которых содержиться деталь
3 | Искать деталь | Вызывает окно поиска детали

Группа «Рисунок» содержит следующие инструменты:

 | Название | Описание
1 | Печать | Вызывает печать страницы каталога выбранной детали.
2 | Вкл/Выкл полноэкранный режим | Переключает вид отображения каталога. По умолчанию программа запускается в не полноэкранном режиме. Включение полноэкранного режима убирает все элементы интерфейса, кроме главного меню и иллюстрации детали.
3 | Увеличить масштаб | Увеличивает масштаб иллюстрации с шагом 10%.
4 | Уменьшить масштаб | Уменьшает масштаб иллюстрации с шагом 10%.
5 | Авторазмер | Автоматически выбирается масштаб картинки, чтобы она полностью помещалась в окно.

Группа «История» содержит следующие инструменты:

 | Название | Описание
1 | Меню "Закладки" | При нажатии на кнопку создается новая закладка на Модель-Узел-Деталь. Выбор из списка открывает соответствующий узел.
2 | Назад | Перемещение по истории на узел назад. Каждое перемещение по узлам заноситься в историю. Можно выбрать Узел-Деталь прямо из ниспадающего списка.
3 | Вперёд | Перемещение по истории на узел вперед.

Группа «Окна» содержит следующие инструменты:

 | Название | Описание
1 | Упорядочить горизонтально | Размещает открытые окна каталога друг над другом.
2 | Упорядочить вертикально | Размещает открытые окна каталога в ряд.
3 | Настройки | Открывает окно настроек.
4 | О программе | Открывает окно, содержащее название и версию программы, а также контактную информацию разработчика.
5 | Справка | Вызов справки

Группа «Заказ» содержит следующие инструменты:

 | Название | Описание
1 | Создать новый заказ |
2 | Удалить заказ |
3 | Показать все заказы |
4 | Показать только черновые заказы |
5 | Показать только подтвержденные заказы |
6 | Показать только заказы в работе |

Группа «Документ» содержит следующие инструменты:

Появляется только для окна документа

 | Название | Описание
1 | Назад | Назад на страницу
2 | Вперёд | Вперёд на страницу
3 | Стоп | Остановить загрузку документа
4 | Обновить | Обновить содержимое страницы
5 | Поиск | Поиск в документе.
6 | Печать | Печать документа на принтер.

Группа «Редактор каталога» содержит следующие инструменты:

 | Название | Описание
1 | Вызов информационного окна | Назад на страницу
2 | Обновить дерево модели | Вперёд на страницу
3 | Режим перетаскивания меток | Остановить загрузку документа
4 | Режим учёта модификаций | Учитывать дату модели для выбора составляющих
5 | Ветку дерева в буфер | Копировать в буфер ТЕКСТОВОЕ СОДЕРЖИМОЕ ветки дерева
6 | SQL запросы | Вызывает онко SQL запросов
AM logo
AM logo
© 2001-2006 ООО "Арт-Механика"


Интерфейс программы

Окно Каталога

Структура узлов и деталей модели Иллюстрация узла Главное меню Панель инструментов детали Панель инструментов структуры модели Панель инструментов детали Панель инструментов поиска Панель инструментов иллюстрации Панель инструментов

1 | Главное меню и панель инструментов
2 | Структура модели (дерево узлов и деталей)
3 | Иллюстрация узла
4 | Поле примечаний деталей и узлов, логических названий узлов
5 | Переключение видов иллюстрации
6 | Панель информации о детали
7 | Список позиций деталей на рисунке (подрисуночная надпись)
8 | Номер текущего окна
9 | Название модели
10 | Маршрут текущего узла

Окно документа

1 | Главное меню и панель инструментов
2 | Поле просмотра документа
3 | Номер текущего окна
4 | Строка состояния документа

AM logo
AM logo
© 2001-2006 ООО "Арт-Механика"


Настройки программы каталога

Окно установок программы можно вызвать через меню "Сервис [image] Настройки". В левой части окна находится дерево содержащее закладки:

маркированный список | Общие
маркированный список | База Данных
маркированный список | Пути к локальным данным
маркированный список | Удалённое соединение
маркированный список | Email установки

Общие:

1 | Выбор страниц настроек
2 | Панель настроек
3 | Кнопка подтверждения изменений

Панель общих настроек содержит следующие параметры:

Название | Описание
Код лицензии | Ваш собственный, индивидуальный номер лицензии. Изменить номер лицензии нельзя.
Язык/Language | Выбор языка каталога. Язык будет изменён после подтверждения (3)
Показывать общее количество деталей в машине | Отображаться количество выбранной детали в окне каталога деталей. Поскольку общее количество вычисляется каждый раз при выборе детали в структуре, это может замедлять работу. Включить/отключить подсчёт количество можно прямо в окне каталога.
Показывать в дереве номера деталей | В структуре узлов и деталей справа от названия узла будет писаться его номер.
Выделять выбранную деталь | На рисунке, метка выбранной детали будет обводиться.
Сглаживать рисунки при масштабировании | При изменении масштаба рисунка, будет использоваться механизм сглаживания. Помогает улучшить качество изображения.
Растягивать рисунки больше 100% при авторазмере | Разрешает при авторазмере в случае если позволяет размер окна, увеличивать рисунки больше 100%. Можно использовать для удобства на больших расширениях экрана.
Запоминать последних используемых моделей | В меню "Каталог" (п.12) определяет количество показываемых последних пользованных моделей.

База Данных

Выбор локальной/сетевой БД для каталога или удалённой через интернет с сервера производителя. Выбор касается работы с БД каталога. Программа может работать одновременно с локальной БД каталога и иметь подключение к серверу. Поэтому, даже если выбран режим работы с локальной БД, при обнаружении интернет сервера, программа требует идентификации пользователя для соединения. Для работы с системой заказов и поиска модели по VIN коду необходимо соединение с интернет сервером. Если убрать флаг "предлагать выбор БД при запуске программы", то программа будет автоматически соединяться к последней выбранной конфигурации.

Пути к локальным данным:

1 | Название конфигурации - имя выбранной конфигурации маршрутов и список конфигураций. Чтобы задать новое имя, просто впишите название и нажмите сохнанить(2)
2 | Кнопки сохранить конфигурацию и удалить конфигурацию.
3 | Строка ввода маршрута
4 | Кнопка вызова окна выбора файла (см. рисунок ниже)

Название | Описание
БД Деталей | Путь к файлу БД Деталей. После корректной установки программы все пути прописаны верно.
БД Заказов | Путь к файлу БД Заказов. После корректной установки программы все пути прописаны верно.
Рисунки цветные | Путь к директории содержащей рисунки каталога.
Текстовые файлы | Путь к директории содержащей текстовые документы каталога.
Файлы Email | Путь к директории содержащей файлы Email.

Кнопки [image] вызывают окно выбора файла:

В верхнем списке выбираем "Рабочий стол \ Мой компьютер \ Нужный диск", далее, выбирая папки доходим до файла, выбираем файл и нажимает ОК.

Кнопки [image] вызывают окно выбора папки:

Раскрывая дерево папок, выделите нужную и нажмите ОК.

Конфигурации маршрутов:

В случае, если у Вас есть несколько дисков с разными моделями, и есть необходимость быстро переключаться между ними, без перезагрузки программы и постоянной смены дисков, можно воспользоваться конфигурациями маршрутов. Изначально в программе имеется только "Основная конфигурация", у неё можно только редактировать маршруты, но нельзя удалить. Если в поле названия конфигурации набрать новое имя, кнопка "Сохранить конфигурацию" [image] станет доступна. Сохраните конфигурацию и задайте маршруты к фацлам.

После этого Вы можете, выбирая из списка конфигураций необходимую, подключать БД с разными моделями. Для удаления ненужных конфигураций имеется кнопка "Удалить конфигурацию" [image].

Примечание: Подключать таким образом можно БД с одним кодом лицензии.

Доступ по сети к данным каталога:

На сетевом компьютере, где будет располагаться БД, должен быть установлен сервер БД - Interbase Server.Для этого произведите установку программы на этом компьютере. Папке, где содержаться рисунки необходим дать доступ для чтения, дадим этому сетевому ресурсу имя "CatalogPicture". На компьютерах, где будет запускаться программа, необходимо её установить, выбрав тип "CD установка". После запуска программы необходимо настроить маршруты к БД и рисункам:

Мартшрут к БД должен выглядеть следующим образом - "\\имя_сервера\маршрут_на_сервере_к_файлу_БД"

Пример: "server\С:\Programm files\INTRALL\Catalogue\DB\INTRALL_SPARES.GDB".

Маршрут к рисункам должен выглядеть следующим образом - "\\имя_сервера\сетевой_мартшрут",

Пример: "\\server\AUTO CATALOG\BMP\".

Таким же образом сделайте маршрут к текстовым документам:

Удаленное соединение:

Название | Описание
Сервер БД | Указывается имя или IP адрес WEB сервера.
Маршрут на сервере | Маршрут на сервере к модулю обработки запросов. Назначается владельцем WEB сервера.
Порт | Назначается владельцем WEB сервера. Обычно задано значение 80
Начальный размер кэшируемых файлов | Определяет минимальный размер файла и запроса, начиная с которого будет производиться сохранение результата в кэш. Кэш позволяет не качать уже раз использованные данные через интернет, а загрузить их с локального диска.
Использовать прокси сервер | Включает использования прокси сервера и его настроек
Сбросить идентификацию пользователя | Сбрасывает идентификацию пользователя, если была включена опция сохранения пользовательских данных (рис. 2 поз 3)

Email установки:

Название | Описание
Способ посылки почты | Можно выбрать программу по умолчанию настроенную в вашей системе или использовать каталог для отправки почты.
Email адрес для отправки сообщений | Адрес получателя почты, т.е. куда будут отправляться заказы (рекомендуем изменять этот параметр только после нашего уведомления о смене электронного адреса).
Установки SMTP | Нужны для настройки отправки почты через Ваш SMTP сервер: SMTP адрес вашего почтового сервера (пример: mail.artmech.com) Port – обычное значение - 25. Account Name на почтовом сервере, обычно то, что стоит слева от @ в Вашем Email адресе. Email – Нужно вписать Ваш Email адрес
Контактная информация | Данные об отправителе (см. ниже). Название фирмы и Email обязательны.
AM logo
AM logo
© 2001-2006 ООО ""Арт-Механика"


Выбор модели

Выбор модели из перечня:

Выбрать закладку "Выбрать модель из списка" (1), раскрывая структуру моделей (2), выбрать интересующую модель.
В поле (4) отображается либо изображение модели либо её описание, в зависимости от наличия изображений/описания модели и выбора закладки (3).
В поле (5) отображаются даты начала и окончания производства модели. Чтобы содержимое каталога наиболее точно соответствовало интересующей машине, необходимо задать дату производства искомой модели (6).
Если у модели есть модификации, становиться доступной кнопка (7), нажатие на которую, приводит к появлению списка модификаций. Выберите из этого списка, ту, которая Вас интересует.

1 | Переключение страниц Списка моделей и Поиска по VIN коду
2 | Структура моделей
3 | Переключение страниц Описания и Изображения модели
4 | Изображение модели
5 | Даты начала и окончания выпуска модели
6 | Выбор даты модели для открытия в каталоге запчастей
7 | Показать/скрыть список модификаций модели

После выбора конкретной модели Вам станет доступна кнопка "ОК", нажав которую Вы откроете Каталог деталей.

Выбор конкретной модели имея VIN номер машины :

Выбрать закладку "Выбрать модель по VIN номеру" (1), ввести в строку поиска номер и нажать кнопку "Найти". В случае успешного поиска, будет выдана следующая информация по модели:

В структуре моделей будет выделена искомая модель, кнопка "ОК" станет доступной.
AM logo
AM logo
© 2001-2006 ООО "Арт-Механика"


Дерево деталей

Дерево узлов и деталей отображает структуру и состав всех узлов машины. Корневым элементом этого дерева является модель. Все узлы машины, включая и саму модель машины, могут быть разобраны на узлы и детали более низкого уровня. Выбор требуемого узла или детали осуществляется либо в дереве узлов и деталей, либо на рисунке, либо в списке узлов и деталей, расположенном под рисунком. При этом в дереве и списке узлы обозначены иконкой - [image], либо [image] - узел имеющий текстовое описание, либо [image] - узел не имеющий иллюстрации. Детали (их раскрыть уже нельзя, т.е. нижний уровень ) отображаются - [image] , либо маленьким изображением детали, если она входит в группу стандартных деталей. Для того, чтобы раскрыть структуру узла, требуется на значке, соответствующем данному узлу, выполнить двойное нажатие левой кнопкой мыши, либо на квадратике со знаком плюс внутри (слева изображения узла) нажать один раз левой кнопкой мыши, после чего этот знак «плюс», меняется на знак «минус» (означает, что узел раскрыт).

1 | Корневой узел модели
2 | Выбранный элемент в структуре
3 | Узел, с пустой иллюстрацией
4 | Номер детали/узла
5 | Деталь
6 | Узел, имеющий описание
7 | Деталь имеющая примечание
8 | Деталь имеющая служебное примечание
9 | .Стандартная деталь (имеет собственную иконку), отличную от иконки детали

Для управления деревом деталей и узлов машины можно использовать панель инструментов .

Нажатие правой клавишей мыши в дереве, вызывает меню, в котором можно вызвать поиск в дереве (быстрый вызовCtrl+Alt+F).

После вызова поиска в дереве, внизу дерева появляется строка поиска, справа от неё - кнопка дальнейшего поиска. Если включен поиск по названию с начальной, набираем в большой буквы название узла. С каждой введенной буквы программа автоматически переходит на первую найденную деталь, если деталь не найдена, курсор дерева не будет сдвигаться. Для того чтобы найти следующую деталь удовлетворяющую заданным параметрам, необходимо нажать кнопку "искать дальше" (справа от поля ввода)

1 | Найденный узел
2 | Строка вода данных поиска
3 | Кнопка дальнейшего поиска (вызов меню настройки поиск)

Поиск в дереве возможен по названию и по номеру, по начальным данным или по включению. Настройка поиска в дереве осуществляется либо вызовом меню pop-up меню (правая кнопка мыши) кнопки дальнейшего поиска, либо в главном меню программы, либо используя панель инструментов.
AM logo
AM logo
© 2001-2006 ООО "Арт-Механика"


Иллюстрация узла

рис. 1

1 | Метка перехода на вида иллюстрации
2 | Метка ссылка на деталь, т.е. такой детали в этот узле нет, но можно быстро перейти на эту деталь в другом узле (отображаются синим текстом с подчеркиванием)
3 | Метка детали (отображаются синим текстом)
4 | Метка выбранной детали (отображаются красным текстом
5 | Метка узла (отображаются фиолетовым текстом
6 | Поле примечаний
7 | Логическое название выбранного узла, т.е. какую роль он выполняет в данном месте конструкции
8 | Служебное примечание, служит примечанием конструктору, при создании каталога. Пользователям не доступно.
9 | Примечание для узла, т.е. примечание действует для этой детали только в этот узле
10 | Примечание для детали, т.е. в любом месте каталога, где встречается эта деталь будет выводиться это примечание
11 | Совместимая деталь (может быть заменена на неё)
12 | Признак наличия выбранной детали на виде иллюстрации. Даёт полезную информацию, в каких видах, кроме текущего изображена текущая деталь
13 | Закладки страниц вида иллюстрации

При подведении курсора к метке он меняет свой вид на [image], все метки с соответствующими номерами выделяются черным кругом, и через короткий промежуток времени возле метки появляется надпись, содержащая название детали или узла и его серийный номер (у некоторых меток номер не отображается, это значит, что у них нет реальных номеров). Если после этого нажать левой кнопкой мыши на метку, то соответствующая деталь или узел выделяются на рисунке (рис. 2), в дереве и списке деталей, отображается информация о детали. При этом метка выбранной детали (4) отображается красным цветом и выделяется такого же цвета окружностью, а выбранная метка узла отображается фиолетовым цветом и тоже выделяется красной окружностью. При нажатии на метку вида происходит переход на другой рисунок, соответствующий номеру вида. При нажатии на метку ссылки на деталь происходит переход на соответствующую деталь в соответствующем узле. Одинаковых меток на рисунке может быть несколько, и все они выделяются при выборе. Если рисунок не помещается на экран и метка не видна по этой причине, то при выделении метки программа сама подвинет рисунок так, чтобы метка была видна на картинке. При этом не все метки могут быть видны (на рисунке может быть несколько одинаковых меток). Двойное нажатие на метке узла приводит к открытию узла, т.е. к переходу на рисунок узла, и выделению первой детали на рисунке.

рис. 2

Для отображения узла может быть сделано несколько видов (несколько иллюстраций). Доступные виды иллюстраций указываются внизу в виде закладок (11). Не все детали могут быть видны на каком-либо из видов, а значит, не будет и метки соответствующей детали на рисунке, соответственно и нет детали в подрисуночной таблице, но в дереве деталей отображается полный список деталей узла. Программа автоматически переходит на ту иллюстрацию, на которой есть метка с выбранной деталью. Если есть несколько иллюстраций с выбранной деталью, программа перейдёт на первый из видов, где имеется деталь, при этом в закладках всех видов, на которых имеется данная деталь отображается маркер наличия (12). Для просмотра всех иллюстраций - воспользуйтесь закладками видов.

Если изображение не вмещается в отведенное ему окно, то можно выполнить следующие действия:

маркированный список | Увеличить размер окна. Между деревом узлов и рисунком имеется вертикальная полоса - разделитель. Если подвести указатель мыши к разделителю, то он принимает вид [image] , при этом если нажать на левую кнопку мыши, то можно перемещать разделитель по горизонтали, тем самым увеличивать по ширине либо дерево узлов, либо изображение узла. Аналогичным образом можно изменить вертикальный размер окна чертежа.
маркированный список | Использовать полосы прокрутки . Если изображение узла не вмещается на весь экран - то на экране появляются полосы прокрутки (скроллеры) изображения, позволяющие перемещать его по горизонтали/вертикали.
маркированный список | Перемещать изображение, нажав на нем левой кнопкой мыши, при этом курсор меняется со стрелки на сжатую руку [image] .
маркированный список | Включить полноэкранный режим [image] .
маркированный список | Изменить масштаб изображения.
маркированный список | Включить режим "Авторазмер изображения"

Для изменения масштаба изображения необходимо на рисунке узла нажать правую кнопку мыши, и в появившемся меню (рис. 3) выбрать “Масштаб изображения” и сам масштаб в процентах. Масштаб может быть 50%, 75%, 100%, 125 %, 150 % и 200 %. После увеличения иллюстрации она обычно не помещается на экран, в этом случае используйте горизонтальный и вертикальный скроллеры для перемещения по рисунку. Если Вы хотите, чтобы иллюстрация всегда помещалась вся в окно – включите режим «Авто» (см. рисунок). Также масштаб можно менять с шагом 10% клавишами "+" и "-" на дополнительной клавиатуре.

рис. 3

В меню изображения также доступны команды:

маркированный список | Редактировать рисунок (только для модуля редактора)
маркированный список | Вперед/Назад по истории узлов
маркированный список | На уровень вверх дерева узлов
маркированный список | Печать изображения
AM logo
AM logo
© 2001-2006 ООО "Арт-Механика"


Панель информации детали

1 | Название детали
2 | Номер детали
3 | Международный таможенный код
4 | Кнопка вызова окна информации стандартной детали
5 | Количество деталей в узле
6 | Масса детали
7 | Количество деталей в ветке дерева (количество родительской детали * количество в узле
8 | Количество деталей во всей машине. При нажатии на название поля включается/отключается функция подсчёта количества, поскольку она занимает некоторое время. Для ускорения работы каталога можно отключить.
9 | Размеры детали. Ширина, Высота. Глубина.

AM logo
AM logo
© 2001-2006 ООО "Арт-Механика"


Подрисуночная таблица

Подрисуночная таблица содержит список деталей всех позиций на рисунке, в том числе ссылки на детали/узлы

1 | Признак детали/узла/ссылки на деталь (иконка)
2 | Метка на рисунке
3 | Признак наличия примечания (зелёный треугольник в правом верхнем углу ячейки)
4 | Количество детали в узле
5 | Выбранная деталь

AM logo
AM logo
© 2001-2006 ООО "Арт-Механика"


Окно "Информация о детали"

У стандартных деталей, внесённых в БД метизов, существует дополнительная информация, поскольку по рисунку невозможно определить, например, что за болт или гайка изображена на нем, а тем более нет информации по их размерам, стандартам и т.п.

Вызов окна информации о детали осуществляется в в панели инструментов иконка [image], а также на панели информации детали (пункт 4).

1 | Название группы, к которому относится деталь
2 | Стандарт детали
3 | Список размеров с примечаниями
4 | Иллюстрация детали с размерами
5 | Кнопка вызова меню
6 | Меню окна

При изменении размера окна масштаб изображений, соответственно, меняется. Для того, чтобы увидеть изображение в полную величину, необходимо увеличивать окно дополнительной информации, пока изображение не прекратит увеличиваться, либо установить опцию “Авторазмер”. Уменьшать изображение можно практически до бесконечности, уменьшая размер окна дополнительной информации. Окно можно привязывать к нижнему или верхнему правому краю, либо не привязывать – тогда окно можно будет перемещать. При отсутствии какой-либо дополнительной информации по детали окно будет пустым. В случае отсутствия в поставке дополнительной информации по деталям окно дополнительной информации появляться не будет. В меню (6) можно привязать окно нижнему или верхнему правому краю главного окна, а также распечатать информацию о детали.
AM logo
AM logo
© 2001-2006 ООО "Арт-Механика"


Информация о модификациях узла

Вызов окна информации о модификациях узла осуществляется в панели инструментов иконка [image] .

1 | Список модификаций по датам (начало, окончание действия)
2 | Список деталей узла в выбранной модификации (1)
3 | Меню окна
4 | Кнопка вызова меню окна (3)

AM logo
AM logo
© 2001-2006 ООО "Арт-Механика"


Поиск узлов и деталей

Для того чтобы найти требуемую деталь по ее номеру или названию, необходимо вызвать окно поиска через меню "Каталог [image] Поиск" или нажав "Ctrl+F". Окно поиска содержит две закладки:

маркированный список | Стандартный поиск
маркированный список | Поиск по группам деталей

Стандартный поиск

рис.1

1 | Выбор типа поиска
2 | Поля ввода информации для поиска
3 | Выбор режима поиска в текущей модели или во всех моделях
4 | Опции отображения информации
5 | Список найденных деталей
6 | Список узлов, где содержится выбранная деталь из списка (4)
7 | Переключение режимов Узел-Модель и Модель-Узел. режим определяет первичность модели или узла. Т.е.будут отображаться все узлы (6), где содержится выбранная деталь (5), и будут отображаться все модели, где есть выбранный узел (6) или будут отображаться все модели, где есть деталь (5), а список узлов (6) будет содержать только узлы в выбранной модели (8)
8 | Список моделей. Если модель не выбрана, список (8) начинает мигать, кнопка (14) при этом будет недоступна.
9 | Список модификаций моделей. Определяет более точно выбранную модель. Доступен только если модель имеет модификации.
10 | Иллюстрация выбранного узла (6) и выделяет все выбранные детали (5)
11 | Дополнительная информация о детали
12 | Размеры к дополнительной информации
13 | Кнопка вызова окна структуры узлов (рис.2) Отображает все местонахождения выбранного узла (6). Позволяет выбрать точный узел в структуре машины для перехода в каталог.
14 | Кнопка подтверждения выбора выбранной детали. не доступна, когда не выбрана деталь или модель.

рис.2
Структура местонахождения узлов (6) в модели, вызывается кнопкой (13)

В полях ввода информации, кроме размеров доступны для использования следующие символы:

* - обозначает использование любых символов в любом количестве
? - обозначает любой одиночный символ в заданной позиции

Регистр букв в названиях не критичен, поиск будет осуществляться без учёта больших/маленьких букв.

Поиск может производиться по всем введённым значениям одновременно. Он может производиться в выбранной модели или во всех моделях. Если вы осуществляете поиск не в текущей модели, вы должны выбрать из списка модель, в которой найдена данная деталь. При выборе детали в модели отличной от текущей, осуществляется переход в каталог выбранной модели.

Примеры:

Задача 1
Задание | Необходимо найти деталь в модели, которая открыта в каталоге с названием “Болт” в текущей машине, и Вы уверены, что точно знаете название
Решение | Включить “Поиск в...” в положение “Текущей модели”. Набрать в поле "Название детали" строку “Болт”.
Результат поиска | 1/2"-13х1,77 Болт 1/2--13х1,38 Болт Деталь ‘1/2"-13х1,77’ находится в: Установка трубопроводов и шлангов гидромеханической передачи
Задача 2
Задание | Необходимо найти деталь по номеру, но номера вы не помните, зато запомнили, что в номере были такие символы “-025”.
Решение | Набрать в поле "Номер детали" строку “*-025*”.
Результат поиска | 020-025-30-2-2 Кольцо 020-025-30-2-3 Кольцо Деталь “020-025-30-2-2” находится в: Трубопроводы и аппараты пневматического привода тормозной системы Панель управления
Задача 3
Задание | Необходимо найти болт с резьбой M10.
Решение | Набрать в поле "Название детали" строку “болт”. Набрать в поле "Размеры" строку "d=M10". необходимо быть уверенным, что искомый размер называется "d". Но, как правило, резьба обозначается так.
Результат поиска | 200317 Болт 200319 Болт Деталь “200317” находится в: Трубопроводы и аппараты пневматического привода тормозной системы Установка трубопроводов и шлангов гидромеханической передачи В данном случае придется просмотреть узлы по названиям, ели включена опция “Показать рисунок”, Вы увидите рисунок узла.

Поиск по группам деталей

рис.3

Отличия от стандартного поиска:

1 | Выбор типа детали
2 | Список и поля выбора размеров
AM logo
AM logo
© 2001-2006 ООО "Арт-Механика"


Поиск узлов где содержится деталь

Поиск, результатом которого является список всех моделей и узлов в которые входит выбранная в каталоге деталь.

1 | Номер и название искомой детали
2 | Список узлов. Содержит в зависимости от переключателя (3) либо все узлы, где содержится деталь, либо узлы входящие в выбранную модель.
3 | Переключение направления поиска Узел->Модель или Модель->Узел
4 | Список моделей. Если выбрано направление Модель->Узел, то список содержит все модели, в которых есть искомая деталь (1). И выбор в этом списке будет определять список узлов (2). Если выбрано направление Узел->Модель, то список содержит модели, в которых есть выбранный узел (2) и при этом список (2) будет определяющим для списка моделей (4)
5 | Иллюстрация узла (2)
6 | Искомая деталь(1) в узле (2). Все позиции детали будут отображены в иллюстрации
7 | Кнопка поиска перехода в каталог деталей. Программа откроет необходимую модель, и раскроет структуру узлов, выделив искомую деталь.

AM logo
AM logo
© 2001-2006 ООО "Арт-Механика"


Печать иллюстрации

: | Печать иллюстрации | Электронный авто каталог 5.x

Печать узла каталога. Вызвать окно печати можно следующими способами:

через меню "Каталог деталей [image] Печать" (быстрая кнопка "Ctrl+P"): |  | нажав правой кнопкой мыши на иллюстрации и выбрать "Печать рисунка":
 | или |

После этого начнётся создание страниц каталога, это может занять некоторое время, в зависимости от объёма документа. В итоге открывается предварительный просмотр созданного документа:

Для печати нажмите кнопку "Печать" на панели инструментов (1)

1 | Панель инструментов управления просмотром и печатью
2 | Название модели, из которой создан документ
3 | Маршрут узлов в модели и печатаемый узел (последний)
4 | Иллюстрация узла
5 | Подрисуночная таблица иллюстрации
6 | Показывает текущую страницу и общее количество в документе

Печать стандартных деталей. В окне информации о детали необходимо выбрать меню "Печать":

Открывается предварительный просмотр созданного документа:

Для печати нажмите кнопку "Печать" на панели инструментов (1)
AM logo
AM logo
© 2001-2006 ООО "Арт-Механика"


Заказ детали

1 | Создание нового заказа
2 | Открытие окна заказов
3 | Удаление позиции заказа
4 | Перемещение позиции внутри заказа
5 | Список рабочих заказов
6 | Дата создания
7 | Дата последнего редактирования
8 | Описание заказа
9 | Название и номер заказываемой детали
10 | Цена детали
11 | Совместимые детали (может быть заменена на неё)
12 | Количество заказываемых деталей
13 | Позиции выбранного заказа

Заказ деталей

Перед тем как заносить заказываемые позиции, необходимо выбрать один из рабочих заказов. Рабочие заказы находятся в списке (5). Вы можете выбрать один из уже существующих заказов, чтобы его дополнить, или создать новый заказ (1). Для выбранного заказа можно изменить его описание (8) , если требуется изменить название заказа, то следует воспользоваться кнопкой (2) и перейти в окно заказов.

Если выбранная деталь в каталоге запчастей может быть заказана, то появятся поля с данными о детали (9,10). В поле "цена детали" ставиться максимальная цена, среди всех номенклатур этой детали.

При наличии взаимозаменяемых деталей, станет активированной кнопка (11). В открывающимся списке находятся номера и названия деталей на которые может быть заменена текущая. Если в списке верхняя деталь отделена чертой, то эта деталь оригинальная для этого узла каталога.

Для занесения детали в позицию заказа, необходимо задать заказываемое количество и нажать на кнопку "поместить в заказ"(12).

Все записи позиций заказа видны в таблице (13), светло-красным цветом подсвечивается позиция которая совпадает с выбранной деталью в дереве каталога. Синим цветом выделяется текущая позиция в заказе. Для изменения номера в заказе у текущей позиции, можно воспользоваться кнопками "вверх" и "вниз" (4), или задать номер вручную двойным кликом щелкнув по ячейке "позиция" в таблице.
AM logo
AM logo
© 2001-2006 ООО "Арт-Механика"


Редактор заказов

Встроенная система заказов

маркированный список | Обеспечивает безошибочный ввод информации с автоматическим указанием дополнительных данных для облегчения поиска взаимозаменяемых узлов и деталей
маркированный список | Ведение БД заказов (создание, удаление, просмотр, редактирование)
маркированный список | Контроль выполнения заказа
маркированный список | Использование общей системы поиска запчастей

Открыть окно редактора заказов, можно выбрав в главном меню "Заказы->Создать окно заказов [image] . Открывшиеся окно содержит следующие элементы:

1 | Создание/удаление заказа (после изменения состояния заказа на готовый, удаление не активно)
2 | Сортировка заказов по их состоянию ("Все заказы", "Только рабочие", "Только готовые" и "Только находящиеся в обработке")
3 | Список заказов
4 | Цена заказа
5 | Дата создания заказа
6 | Дата последнего изменения. Если дата имеет зеленый цвет - то дата примерной отгрузки.
7 | Состояние заказа
8 | Название заказа
9 | Описание заказа
10 | Таблица позиций заказа
12 | История позиции
13 | Описание позиции

Внутри узла "Собственные" находятся все заказы сделанные вами. Заказы могут иметь несколько разрядов:

маркированный список | Рабочий. Заказ который можно редактировать.
маркированный список | Готовый. Законченный заказ. Заказ помеченный этим разрядом, нельзя изменить.
маркированный список | Находящийся в обработке. Такое состояние заказ имеет, пока он обрабатывается складами запчастей.
маркированный список | Сформирован частично.
маркированный список | Сформирован.
маркированный список | Отгружен частично.
маркированный список | Отгружен.
маркированный список | Закрыт. Закрытый заказ. Заказ больше не может изменять свой статус.

Для перемещения заказа из статуса "Рабочий" в "Готовый" необходимо вызвать выпадающие меню, щелкнув правой клавишей мыши на выбранном заказе. Все остальные статусы заказов изменяются работниками складов.

Состояние "Находящийся в обработке", означает что заказ принят и началась обработка. По окончанию обработки, все дальнейшие статусы состояния заказа будут отображаться в списке заказов.

Когда назначат примерную дату отгрузки, дата (6) примет зеленый цвет.
AM logo
AM logo
© 2001-2006 ООО "Арт-Механика"


Горячие клавиши

Комбинация клавиш | Действия
Ctrl+N | Создать новое окно каталога
Ctrl+P | Печать страницы каталога
Ctrl+F | Поиск деталей
Ctrl+Alt+F | Поиск детали в узле (ветке дерева)
Ctrl+D | Вызов окна "Заказ детали"
Ctrl+O | Создать окно "Заказы"
Ctrl+B | Установить закладку
Ctrl+Alt+M | Включить/Выключить полноэкранный режим
Ctrl+Alt+A | Включить Авто-масштабирование иллюстраций
Ctrl+Alt+H | Упорядочить окна горизонтально
Ctrl+Alt+V | Упорядочить окна вертикально
Alt+F4 | Закрыть окно
+/- на доп. клавиатуре | Изменить масштаб изображения
AM logo
AM logo
© 2001-2006 ООО "Арт-Механика"


Контакты

Электронный каталог БелАЗ версии 4.x

Технологии компьютерного дизайна
для машиностроения

Адрес: | Беларусь, г. Минск 220121, ул. Притыцкого д.60/4, офис 804
Факс: | (375 17) 259-43-36
E-mail: | info@artmech.com
WEB: | www.artmech.com
AM logo
AM logo
© 2001-2006 ООО "Арт-Механика"


Возможные проблемы

Электронный каталог БелАЗ версии 4.x

Проблема

Причина

Решение

При установке выводится сообщение "Ошибка копирования файла ...." | Операционная система не поддерживает русский язык ( причина в непонимании русских символов в именах файлов). | Установить поддержку русского языка
При запуске появляется заставка, затем программа заканчивает работу, никаких сообщений при этом не выводиться | Нарушен или не найден файл лицензии | Переустановить каталог
Файл программы каталога поврежден | Переустановить каталог
Произошел сбой во время работы программы, или программа некорректно завершилась | Переустановить каталог
Истек срок действия лицензии | Обратиться к производителю и обновить программу и базу данных или обратиться за продлением лицензии
Выводиться сообщение "Ошибка запуска сервера БД" | На медленных компьютерах (100-200МГц) программа может не дождаться запуска сервера Базы Данных. При этом в системном трэе( внизу справа) появляется иконка сервера БД [image] или [image]. после закрытия программы | Запустить повторно программу каталога
Не возможно запустить сервер БД - не появляется иконка или она мигает красным:
  1. Не установлен InterbaseServer
  2. Некорректный файл gds32.dll
  3. Установлен InterbaseServer версии ниже 6
  4. Ошибка в операционной системе и происходит ошибка в работе сервера БД (иконка мигает красным)
  5. Ошибки в настройках InterbaseServer
По пунктам соответственно:
  1. Установить InterbaseServer отдельно или переустановить программу каталога
  2. Удалить файл gds32.dll из Windows\System\ (Win95/98) и WinNt\System32\ (Win2000) и переустановить программу каталога
  3. Переустановить программу каталога
  4. Удалить операционную систему и установить заново (Были случаи, когда лечилось только этим). Причина - порча в ОС каких-то жизненно необходимых файлов другими программами (перезапись более старых версий и .т.д.)
  5. Позвать администратора разобраться в настройках
Выводиться сообщение "Вставьте компакт диск в CD-ROM и повторите !" | Не найден установочный компакт диск с программой каталога | Программа была установлена с установкой "работать с компакт-диска", надо либо поставить диск с программой, либо настроить маршруты к БД.
Выводиться сообщение "Не могу открыть Базу Данных" | Не найден файл Базы Данных | Файл БД находиться как правило в директории "Program files\BELAZ\Catalogue\DB" и имеет имя "Parts.gdb" - если он там отсутствует - скорее всего причина в типе установки программы "работать с компакт-диска". В этом случае для работы с жесткого диска необходимо переустановить программу выбрав тип установки "Полный". Нужно настроить маршрут к БД в окне "Установки", закладка "Пути к файлам".
Код клиента БД не соответствует коду клиента программы | Используйте собственную БД
Функции работы с заказом недоступны Не найден файл БД заказов или он не входил в поставку системы Файл БД находиться как правило в директории "Program files\BELAZ\Catalogue\DB" и имеет имя "Orders_1.gdb"

Необходимо настроить маршрут к БД Заказов в окне "Установки".

Старая версия БД заказов и проблема с её обновлением. | Удалите БД заказов перед установкой программы (Orders_1.gdb)
Не выводятся рисунки узлов | Неправильно настроен маршрут к файлам рисунков | Войдите в раздел "Установки" закладка "Пути к файлам" и настройте маршруты
Нарушена целостность программы или лицензия не соответствует программе | Вы нарушили лицензионное соглашение - удалите программу с вашего компьютера

AM logo
AM logo
© 2001-2004 ООО "Арт-Механика"


Лицензия

AM logo
AM logo
© 2001-2006 ООО "Арт-Механика"